SOLVED At the stage of powering on to tune the stepper drivers and I have no life on the LCD

Discussion in 'Build Help' started by Turtle, Jul 7, 2016.

  1. Turtle

    Turtle Member

    Joined:
    Mar 14, 2016
    Messages:
    14
    Likes Received:
    1
    I've just got to the point of first power on to tune the stepper drivers but I have nothing on the LCD display. Swapped the ribbon cables as suggested and still nothing.

    Troubleshooting guide is "coming soon" so now am at a dead halt. The two 24 DC supplies have power and the electronics cover fan is spinning so power is getting to the Rumba.

    Any suggestions because clearly something is very wrong, I cannot see any mistakes on the wiring but with no LEDs and no LCD screen I am in the blind.
     
  2. Alex9779

    Alex9779 Moderator
    Staff Member

    Joined:
    Sep 4, 2015
    Messages:
    2,405
    Likes Received:
    731
    Is the back light on of the LCD?
    If so try to adjust the contrast, unfortunately the potentiometer is only accessible with a needle nose pliers and you have to disassemble the LCD housing....
     
  3. Turtle

    Turtle Member

    Joined:
    Mar 14, 2016
    Messages:
    14
    Likes Received:
    1
    I found the problem after going over the wiring for a third time, my X axis stop connector was over one pin (left of the three) and that stopped the Rumba from booting.

    I put it down to my crap eyesight....

    Thanks for the reply though.
     
    Alex9779 likes this.

Share This Page