avrdude error

Discussion in 'BigBox General Chat' started by Martin Low, Jul 25, 2016.

  1. Martin Low

    Martin Low Member

    Joined:
    May 20, 2016
    Messages:
    24
    Likes Received:
    0
    Hi,

    I'm trying to check my firmware version and update if possible but I am getting an error through avrdude.

    I installed the firmware updater using the plugin manager, which worked.
    I then installed avrdude with PuTTY using the two commands
    sudo apt-get update
    sudo apt-get install avrdude
    Again this worked.
    I then went into the spanner in the firmware updater and changed the path to /usr/bin/avrdude.

    I then put https://github.com/BigBox3D/Firmware/blob/master/marlin_hybrid_pro.hex in the URL field and click flash to drive and the following pops up:

    AVRDUDE error: No valid record found in Intel Hex file "/tmp/tmpWZMqb0"
    avrdude: read from file '/tmp/tmpWZMqb0' failed

    avrdude done. Thank you.


    Any ideas?

    Thanks.

    [Update] I tried downloading the file and flashing it from file and it worked fine.
     
    #1 Martin Low, Jul 25, 2016
    Last edited: Jul 25, 2016
  2. Alex9779

    Alex9779 Moderator
    Staff Member

    Joined:
    Sep 4, 2015
    Messages:
    2,405
    Likes Received:
    731
    I think the problem here was that Github is not really serving binary files out of repositories properly.
    That's why I put up the firmware on the release page of the Marlin fork for the BigBox, see https://github.com/BigBox3D/Marlin/releases
    If you copy those links and put them into the URL field it should work...
     

Share This Page