SOLVED BB-Dual v1.1 Hybrid auto-level settings not saved?

Discussion in 'Calibration, Help, and Troubleshooting' started by SandervA, Mar 4, 2017.

  1. SandervA

    SandervA Member

    Joined:
    Aug 3, 2016
    Messages:
    13
    Likes Received:
    1
    Hey guys,

    Perhaps I'm missing something obvious here, but I just can get my BB-Dual to auto-level properly. The IR-sensor is working fine in my setup; quite accurate, very consistent, not the problems other people seem to have. It auto-homes perfectly. The I run Bed level and it does this perfectly as well; meaning that it finds the same (by eyeball) distance to the bed. However, when I start the print it seems to ignore the information of the leveling and assumes a perfect level bed, resulting in partial air-printing (right side) and partial correct printing (left side).
    Any ideas?
    FYI: I'm printing via Octoprint.

    The reason why I'm set on printing with a slightly uneven bed is to avoid scraping of the second extruder on the plastic just laid down by the first.

    Many thanks in advance,
    Sander
     
  2. Spoon Unit

    Spoon Unit Well-Known Member

    Joined:
    Sep 6, 2015
    Messages:
    1,095
    Likes Received:
    322
    If you're not seeing the z screws moving then something regarding levelling isn't working. What firmware are you on? I've never used Auto-level though. Any reason why you're sticking what that rather than manual-mesh?
     
  3. SandervA

    SandervA Member

    Joined:
    Aug 3, 2016
    Messages:
    13
    Likes Received:
    1
    That would be Marlin 1.1.0 RC6.
     
  4. SandervA

    SandervA Member

    Joined:
    Aug 3, 2016
    Messages:
    13
    Likes Received:
    1
    So how would you do a manual-mesh?
     
  5. Henry feldman

    Henry feldman Well-Known Member

    Joined:
    Sep 5, 2015
    Messages:
    969
    Likes Received:
    389
    This has happened to me 3 times over the life of my BigBox. I re flashed with @Alex9779's original firmware files which worked great and that fixed it. No idea how the bed-leveling-compensation flag seems to get corrupted, but it does...
     
    SandervA likes this.
  6. SandervA

    SandervA Member

    Joined:
    Aug 3, 2016
    Messages:
    13
    Likes Received:
    1
    Dear Henry,

    Thanks, this is very helpful. I was already looking into the reflashing and was about to decide against it as my version seems to be the most current for de Dual Hybrid BB. So it's good to know that I should try it anyway. Many thanks,
    Sander

    Ps. I'll post my findings in this thread for future reference by others experiencing the same problem.
     
  7. Spoon Unit

    Spoon Unit Well-Known Member

    Joined:
    Sep 6, 2015
    Messages:
    1,095
    Likes Received:
    322
    These are the settings that relate to manual mesh levelling in my firmware config:
    upload_2017-3-5_9-48-53.png
     
  8. SandervA

    SandervA Member

    Joined:
    Aug 3, 2016
    Messages:
    13
    Likes Received:
    1
    Just to keep everyone updated; reflashing did not solve the problem for me. Removing G28 auto home from the custom start G-code in Slic3r did. Apparently, this resets the auto-leveling.

    Many thanks for all the help.
     

Share This Page