COMPLETE BigBox + DuetWifi controller

Discussion in 'Guides, Mods, and Upgrades' started by elmoret, Jul 17, 2016.

  1. mhe

    mhe Well-Known Member

    Joined:
    Sep 5, 2015
    Messages:
    149
    Likes Received:
    36
    I will do so once the machine is up and running again, at the moment it is in pieces as I am rebuilding it with the IDEX system, BLTouch, integrated leadscrew Z motors and sleeving all the cables individually to keep things tidier. The Bigbox in its original design is a horror to assemble and disassemble but it is a wonderful machine once it works.

    I'll let you know once I managed to isolate the commands that cause the trouble - if it still does that thing once I moved over to the BLTouch and automated 2-point Z leveling. I guess @K3LAG 's config will be a good starting point, so I'll start from there.
     
  2. sebastiaan

    sebastiaan Member

    Joined:
    Mar 22, 2016
    Messages:
    21
    Likes Received:
    3
    Question about homing the axis and the right config for it. Below is the config script I use for homing the z-axis. I copied it from a post in this topic. When i try to home the z-axis I get the error that there are insufficient axis homed. When I comment line G1 Z5 F200 that error is resolved but a different error is given:
    Code:
    Error: Z probe already triggered at start of probing move
    Error: G0/G1: insufficient axes homed
    
    The bed is already at the top of the printer causing the z-probe to trigger so the error about the z proby already triggered is correct. However when I try to move the bed down the error about insufficient axes homed is given.

    The x and y axis are homed.

    I seem to be stuck in a loop as i can't seem to move the bed down without homing it and can't home without moving the bed down.

    Any ideas on how to get out of that loop?

    homez.g
    Code:
    T0                  ; select first hot end
    G91                 ; Relative coordinates
    G1 Z5 F200          ; Lower bed to avoid hotend dragging in bed.
    G90                 ; Absoulte coordinates
    G1 X35 Y15 F3000    ; Go to first bed probe point and home the Z axis
    G30                 ; Calibrate Z-axis
    G1 Z1 F200          ; Raise bed to 1mm.
    
     
  3. Ephemeris

    Ephemeris Well-Known Member

    Joined:
    Nov 25, 2015
    Messages:
    379
    Likes Received:
    229
    Two questions:
    1) Was hming previously working?
    2) What version of the Duet firmware are you using?
     
  4. sebastiaan

    sebastiaan Member

    Joined:
    Mar 22, 2016
    Messages:
    21
    Likes Received:
    3

    First time the homing worked as the bed was lowered and needed to raise. It triggered the z-probe just fine. Homing x and y also work as long as I don't add a line to the home script to lower the bed.

    The Duet is running firmware version 2.0(RTOS) (2018-06-05b3). It was delivered with this version installed.

    I just upgraded the firmware to 2.02beta1(RTOS) (2018-08-12b5) but that didn't solve the problem
     
    #384 sebastiaan, Aug 31, 2018
    Last edited: Aug 31, 2018
  5. Ephemeris

    Ephemeris Well-Known Member

    Joined:
    Nov 25, 2015
    Messages:
    379
    Likes Received:
    229
    Did you have the command
    M564 H0
    in your config.g?
     
    sebastiaan likes this.
  6. sebastiaan

    sebastiaan Member

    Joined:
    Mar 22, 2016
    Messages:
    21
    Likes Received:
    3
    Thanks! Now I do :) Did not know that command existed. Was able to move the bed down and then home it.

    Ok, last question. The extruder motor stutters. Instead of a smooth movement to extrude or retract instead the movement is a stutter and the filament doesn't move. The hotend is brand new, nothing stuck in it and I can easily move the filament up and down by hand.

    The motors for x, y and z do not have this problem. Probably a setting i'm missing or are the motors wired incorrectly? Both extruders have the same issue.
     
    #386 sebastiaan, Aug 31, 2018
    Last edited: Aug 31, 2018
  7. Ephemeris

    Ephemeris Well-Known Member

    Joined:
    Nov 25, 2015
    Messages:
    379
    Likes Received:
    229
    If you remove the filament and just let it sit there, do the steppers make a buzzing noise? That would be a sign the stepper is miswired.

    Of course the Duet will not even try to turn the extruder steppers unless your temperature is the minimum set by M302. The default is supposed to be 160C
     
  8. sebastiaan

    sebastiaan Member

    Joined:
    Mar 22, 2016
    Messages:
    21
    Likes Received:
    3
    The steppers are not making any buzzing noise. I just checked with the fans off so I could hear it. Before I heated the extruder to 210 degrees so filament should come out. I've checked the connection and the extruder motors are wired the same way as the axis motors and those all work.
     
  9. Rob Heinzonly

    Rob Heinzonly Well-Known Member

    Joined:
    Sep 20, 2015
    Messages:
    403
    Likes Received:
    144
    A stutter in stepper motors is most of the times caused by wrong wiring. I noticed that not all stepper motor wires are color coded the same. You can check it by measuring the resistance over the wires.
     
    Spoon Unit and sebastiaan like this.
  10. sebastiaan

    sebastiaan Member

    Joined:
    Mar 22, 2016
    Messages:
    21
    Likes Received:
    3
    It was the wiring. Changed the cables around and now they work. Thank you!
     
    Rob Heinzonly and mhe like this.
  11. mhe

    mhe Well-Known Member

    Joined:
    Sep 5, 2015
    Messages:
    149
    Likes Received:
    36
    And if you don't have any multimeter ready, simply connect 2 wires of a motor and try to spin it by hand - if you connect 2 wires together that form a pair, the spinning becomes harder to do. So you can actually figure out how to connect a motor without knowing the wire color code :)

    Also what might be helpful for understanding:
     

Share This Page