Connecting via USB fails on Windows10

Discussion in 'Calibration, Help, and Troubleshooting' started by PeterStuttgart, Jul 30, 2016.

Tags:
  1. PeterStuttgart

    Joined:
    Jun 8, 2016
    Messages:
    13
    Likes Received:
    1
    Good morning,

    I made my first successful test print last night from the SD card. Now I wanted to take the next step and connect via USB (no OctoPrint here). Unfortunately it seems there is a problem with the Rumba driver for Windows10. Whenever I connect the cable it states that the device is not recognized and in the device manager it shows up as "Unknown USB Device (Device Descriptor Request Failed)".

    Has anyone else that problem?

    Peter
     
  2. Ben Bajorek

    Ben Bajorek Member

    Joined:
    May 31, 2016
    Messages:
    6
    Likes Received:
    0
    I was having troubles with connecting to the printer. Have you tried opening your slicer program first without the printer's USB connected, set the baud rate to 230400 and then insert the cable into your computer USB port? That works on my MacBook.
     
  3. jfb

    jfb Well-Known Member

    Joined:
    Mar 30, 2016
    Messages:
    91
    Likes Received:
    18
    I've successfully flashed the Rumba from my windows 10 laptop, and had no issues, but only did a few rudimentary control moved to test at the time and not tried USB connection since - I use Octopi, which isn't much help to you. It looks though like quite a few people have had similar issues. Hopefully you might find something here that will help http://reprap.org/wiki/RUMBA#Troubleshooting
     
  4. PeterStuttgart

    Joined:
    Jun 8, 2016
    Messages:
    13
    Likes Received:
    1
    jfb: Unfortunately my problem is not described there. But thanks for the link anyway. It may come in Handy for other Problems that I may come across in the future.
    Ben: I couldn't muster the Patience yet to test all possible orders of plugging, switching on/off and Setting baud rates. But I'll give it s shot ...
     
  5. PeterStuttgart

    Joined:
    Jun 8, 2016
    Messages:
    13
    Likes Received:
    1
    Hmm ... I dug up an old laptop and installed Win10 there (same Version as on my desktop) and it connects just fine. So I guess it's either a hardware problem on my desktop (but I think I had other devices connected the same way - COM via USB - before and it worked) or a bad USB cable. It's rather long (10 Meters). So I ordered a repeater enhanced USB cable and will try that as soon as it arrives. I'll keep this post updated if that helps.
     
  6. Jasons_BigBox

    Jasons_BigBox Well-Known Member

    Joined:
    Mar 25, 2016
    Messages:
    232
    Likes Received:
    69
    Hi Peter,

    I'm running Windows 10 too. I installed the driver and connected to the BB without too much of an issue but I couldn't do anything else until I set the baud rate to 230400 in S3D as described above. After that I can use S3D to control the printer.

    I found that xloader (to update firmware) doesn't work unless you set the baud rate to 115200 in xloader.

    I have had plenty of problems with other USB hardware getting connected, my Mobius camera in particular was a pain and I tried all kinds of things to get it to work. It didn't help that the camera is recognised as both a camera and a flash drive.

    I'm afraid it's not a solution but it may be worth uninstalling the driver and re-installing if the baud trick doesn't help.

    Good luck,

    Jason
     
  7. PeterStuttgart

    Joined:
    Jun 8, 2016
    Messages:
    13
    Likes Received:
    1
    Hi Jason,

    thanks for the idea, but the problem occurred earlier than where the baud rate would come into play. Windows doesn't recognize the RAMPs device type. From the laptop I also had to set the baud rate to 230400, but I think I read about that before somewhere. Well, we'll see if the new cable helps (which will be delivered Tuesday ... what happened to "next day delivery" for prime members at our favorite online shop? ... But I'm getting off topic ;) )

    Peter
     
  8. PeterStuttgart

    Joined:
    Jun 8, 2016
    Messages:
    13
    Likes Received:
    1
    Yep, it's been the cable. 10 Meter USB without a repeater is too much... Thank you guys for the ideas!
     

Share This Page