dock position wrong after canceled print

Discussion in 'Calibration, Help, and Troubleshooting' started by Digi2life, Feb 25, 2017.

  1. Digi2life

    Digi2life Member

    Joined:
    Apr 22, 2016
    Messages:
    23
    Likes Received:
    4
    OK, folks, I've been having better luck with the BigBox lately, but I really need to fix this issue:

    I have a hybrid dual and the beginning of my start script is below. Basically, the printer homes fine and positions itself correctly in the dock and life is good. But if I cancel a print, any print I try next will put the head to the right of the dock. I'm sure it's related to the nozzle offset, but I have no idea why the position get confused after canceling a print. I have to reset the machine to fix the issue.

    Oh, this might be important. T0 is left bowden. T1 is right direct. I nearly always print with T1, and that's where I know there is an issue. I can see if this happens when printing only with T0 I suppose, but I'm hoping someone else has seen this issue and can help. Thank you!!!!

    Code:
    ;BigBox Hybrid-Dual Start Script Begin
    ;relies on M83 (use relative extrusion distances)
    
    ;home
    G28
    
    M117 Preparing
    M190 S50 ; wait for bed to reach 50C
    M140 S[bed0_temperature] ; set bed temperature
    M104 S[extruder0_temperature] T1; set extruder temperature
    
    ;set values
    M92 E409.2 ; adjust steps per mm for your filament
    M218 T1 X38.25 Y-0.15; set extruder 1 offset
    
    ; lift the head
    G91 ; relative positioning
    G1 Z5 F360 ; move Z axis by 5mm
    G90 ; absolute positioning
    
    ;move to dock
    T0 ; select extruder 0
    G1 X70 Y200 F3000 ; move to position in front of dock
    G1 X70 Y235 F3000 ; move into dock
     
  2. Greg Holloway

    Greg Holloway Administrator
    Staff Member

    Joined:
    Sep 4, 2015
    Messages:
    565
    Likes Received:
    397
    Make sure you have the correct code in the Cancel script part in the octoprint settings. You might need to adjust the numbers.....

    You could also add T0 to the beginning of your start script, BEFORE the G28 command otherwise it will try and do all the commands, including the homing, with T1.

    It's a bit of a silly bug or it might be a feature, I'm not sure which.
     

Share This Page