Extruder carriage ends up in slightly the wrong place

Discussion in 'Calibration, Help, and Troubleshooting' started by Duncan Chivers, Sep 16, 2016.

  1. Duncan Chivers

    Duncan Chivers Well-Known Member

    Joined:
    Apr 19, 2016
    Messages:
    103
    Likes Received:
    5
    Hi All, this isn't a major problem, more of an annoyance.
    When my prints finish, the main extruder carriage ends up slightly to the left of the cutout on the back of the frame, which means it always does an awkward jerking movement (because it didn't expect something to be in the way).
    It doesn't do it at the beginning of the job, and finds the bucket nicely to extrude a small amount of filament.

    I've attached a photo for reference.

    Any ideas?
     

    Attached Files:

  2. Mark Curry

    Mark Curry Well-Known Member

    Joined:
    Jan 17, 2016
    Messages:
    81
    Likes Received:
    6
    Add 10mm to the X axis value in S3D for ending script. Its in the script tab. You will see a comment "move to dock" then there will be 2 G! commands one in front of dock and one into dock. You need to change both. Mine are:

    G1 X115 Y200 F3000 ; move to position in front of dock

    G1 X115 Y235 F3000 ; move into dock

    You may need to change the X value to more or less depending where yours is positioned.
     
    Dominic likes this.
  3. Duncan Chivers

    Duncan Chivers Well-Known Member

    Joined:
    Apr 19, 2016
    Messages:
    103
    Likes Received:
    5
    Thanks Mark, I'll give that a try.
     
  4. Duncan Chivers

    Duncan Chivers Well-Known Member

    Joined:
    Apr 19, 2016
    Messages:
    103
    Likes Received:
    5
    Thanks Mark, that has worked.

    I've also amended the starting script to have the same values, and it drops into the correct place before it starts, but now the autohome is slightly out, and it's catching the bed clip as it goes to 0,0.

    Is there another setting I need to amend to bring that back a few mm?
     

Share This Page