Heater Issue

Discussion in 'Troubleshooting' started by Athul S Nair, Aug 31, 2019.

  1. Athul S Nair

    Athul S Nair Member

    Joined:
    Mar 10, 2019
    Messages:
    4
    Likes Received:
    0
    Hello,
    I'm having a strange problem with one with one of my printer (I'm not near the machine but it is with my cousin, sadly I'm like 3500 Km from the machine). It is a custom machine (modified CNC) running on Marlin + RAMPS 1.4. It doesn't have any Heated bed, so print material is only PLA. Printer is placed in air conditioned room set @ around 23 Degrees.

    It has Original E3D Titan Extruder + V6 hot end Direct drive mechanism. It was working fine for around a year. Recently he reported that the heater is failing to reach set temperature. Hotend can go as much as 190 -195 Degrees. I have used that printer for printing PLA @ 210 Degree Celsius with out any issue (with the same atmospheric temperature right now). I have tried to check the issue by connecting through Anydesk and I could see it's taking a long time to reach temperature of 190 and stays at around 195 C then fails with "Heating failed Error".
    But what seems strange is sometimes it reaches the set temperature of 210 Degree in normal rate but fails most times. I played with Marlin Thermal runaway protection settings but not helped. I asked him to turn the AC off and check it, but failed with same error. So I bought an original E3D 12V 30W heating coil and sent it to him. He was able to replace it and able print some sample. But yesterday he told me that, it is showing same error.

    So what could be the reason. I have checked the hotend before sending it to him, it was heating faster and able to go up 250 Degrees (That's the max I tried but heating coil could go above that).

    I have told him to connect the heater directly to SMPS and I monitored the temperature via Anydesk. I could see it's going too slow when it reaches around 190. It was able to reach 218 though. But when I extruder some filament it reduced to around 205C which would definitely cause error

    Any idea what's the issue ?
    Any other suggestions ?
    What could other things that might cause this issue?

    Heating through controller. It took 20 minutes to reach 23 Degrees to 195 C

    Ne1.PNG

    Directly connected to PSU. Dip in graph is when extruded filament

    Thanks
     

    Attached Files:

  2. Spoon Unit

    Spoon Unit Well-Known Member

    Joined:
    Sep 6, 2015
    Messages:
    1,560
    Likes Received:
    483
    Maybe try PID tuning the hotend. If it thinks (due to previous or default tuning) that the heater can never reach temp, it will eventually shut down. 20 mins is crazy long for a hot end to reach temp. I have the same heater in my hotends and it will go from room temp to 220 in about 4 mins.

    M303

    This will tell you the current P, I, and D settings on your printer.

    M303 H1 S240

    This says to run a heating test on Heater 1 up to 240 degrees. The board firmware decides what to do next, but should ultimately spit out some numbers which you can either set during your start script or configure into the firmware if you want to recompile.
    Heater 0 is usually the bed, but as you have no bed heater, it's possible that your heater is heater 1.

    M301

    This is how you set PID params using the output from M303.
     

Share This Page