Hotend Jamming. How have auto 12v fan Rumba?

Discussion in 'E3D-v6 and Lite6' started by dodgersfan24, Aug 4, 2015.

  1. dodgersfan24

    dodgersfan24 Member

    Joined:
    Aug 4, 2015
    Messages:
    2
    Likes Received:
    0
    I have done everything, the only thing that I haven't checked of the list for jamming problems is that My fan is not on direct 12v. Does anyone know how to do this on a rumba board?
     
  2. dodgersfan24

    dodgersfan24 Member

    Joined:
    Aug 4, 2015
    Messages:
    2
    Likes Received:
    0
    Since no one has had the oppurtinity to respond, I'll do it if anyone else has this problem.

    I wired the fan with the screws on FAN1 on the the board. Then added this line to the firmware on configuration.adv/h
    Changed the -1 to 8 for rumba

    #define EXTRUDER_1_AUTO_FAN_PIN 8

    Then changed the tempature fromm 50 to 0 because I want to have it always on.

    Did it to this part of configuration.adv.h


    // Extruder cooling fans
    // Configure fan pin outputs to automatically turn on/off when the associated
    // extruder temperature is above/below EXTRUDER_AUTO_FAN_TEMPERATURE.
    // Multiple extruders can be assigned to the same pin in which case
    // the fan will turn on when any selected extruder is above the threshold.
    #define EXTRUDER_0_AUTO_FAN_PIN -1
    #define EXTRUDER_1_AUTO_FAN_PIN 8
    #define EXTRUDER_2_AUTO_FAN_PIN -1
    #define EXTRUDER_AUTO_FAN_TEMPERATURE 0
    #define EXTRUDER_AUTO_FAN_SPEED 255 // == full speed

    NOTE: If you add pin 8 to this as above, you have to remove the pin from the list in pins.h
     

Share This Page