inconsistent acceleration

Discussion in 'Calibration, Help, and Troubleshooting' started by A Dragon In A Pie Costume, Jan 9, 2017.

  1. A Dragon In A Pie Costume

    A Dragon In A Pie Costume Well-Known Member

    Joined:
    Jul 6, 2016
    Messages:
    203
    Likes Received:
    15
    after recently upgrading to rc8 whenever I try to print anything it will randomly slow down, this will also happen with older gcode file, when I set the acceleration to 0 it works again but I'm assuming it's bad for the machine..

    anyone else experienced this?

    thanks in advance,
    dpie.
     
  2. Spoon Unit

    Spoon Unit Well-Known Member

    Joined:
    Sep 6, 2015
    Messages:
    1,095
    Likes Received:
    322
    Not seen that and I'm on RC8. Not totally clear what you mean? Is it on a particular layer?
     
  3. Greg Holloway

    Greg Holloway Administrator
    Staff Member

    Joined:
    Sep 4, 2015
    Messages:
    565
    Likes Received:
    397
    I'm having exactly the same thing happen on my dev machine. I thought it was something to do with the LIN_ADV feature but it's not.

    I have switched off all the fancy features and it still does the same thing.
     
  4. Spoon Unit

    Spoon Unit Well-Known Member

    Joined:
    Sep 6, 2015
    Messages:
    1,095
    Likes Received:
    322
    Here's my setup in case it helps

    chrome_2017-01-09_15-13-04.png
    chrome_2017-01-09_15-14-05.png
    chrome_2017-01-09_15-14-47.png
     
  5. A Dragon In A Pie Costume

    A Dragon In A Pie Costume Well-Known Member

    Joined:
    Jul 6, 2016
    Messages:
    203
    Likes Received:
    15
    the print would randomly slow down an speed up again, when running the same gcode it appears to happen at the same spots, it affects both new and old gcode... it happens almost on every layer but not when it moves up, my theory is that marlin is ignoring some of the G1 Fx commands, but no errors are shown when doing via usb(I tested on both ad and over usb, same happens)


    a "fix" for it would be to set the acceleration value to 0, but it makes horrible noises when stopping/changing directions and I can't imagine that's good for the steppers...
     
  6. markoaurelije

    markoaurelije Active Member

    Joined:
    Dec 21, 2015
    Messages:
    43
    Likes Received:
    6
    Yep, I'm having it too :(
     
  7. A Dragon In A Pie Costume

    A Dragon In A Pie Costume Well-Known Member

    Joined:
    Jul 6, 2016
    Messages:
    203
    Likes Received:
    15
    I'm gonna try copying spoon's settings to see if that helps
     
  8. Spoon Unit

    Spoon Unit Well-Known Member

    Joined:
    Sep 6, 2015
    Messages:
    1,095
    Likes Received:
    322
    Note that it's a different repo too then. And alter the probe offset per your print head.
     
  9. A Dragon In A Pie Costume

    A Dragon In A Pie Costume Well-Known Member

    Joined:
    Jul 6, 2016
    Messages:
    203
    Likes Received:
    15
    I thought the baud rate is supposed to be in the 20k's?
     
  10. tohara

    tohara Well-Known Member

    Joined:
    Sep 5, 2015
    Messages:
    128
    Likes Received:
    59
    The default baudrate is in the 230400, but it need to be reduced to 115200 if you are using LIN_ADVANCE.
     
  11. Greg Holloway

    Greg Holloway Administrator
    Staff Member

    Joined:
    Sep 4, 2015
    Messages:
    565
    Likes Received:
    397
  12. EpicFail

    EpicFail Active Member

    Joined:
    Apr 22, 2016
    Messages:
    38
    Likes Received:
    4
    is this possibly why a 2 inch tall super thin print is taking over 3 hours? .-.
     

Share This Page