IR sensor only working on Auto Home

Discussion in 'Build Help' started by SoBaldrick, Mar 21, 2016.

  1. SoBaldrick

    SoBaldrick Well-Known Member

    Joined:
    Sep 15, 2015
    Messages:
    99
    Likes Received:
    66
    my IR sensor is triggering fine when i auto home, but when i try Bed Level, it fails to trigger on the first corner, bed just keeps rising until it hits the end stops, managed to get it to move over to second corner by putting some glue stick on the corner, but that's not a real fix.. any ideas.....
     
  2. SoBaldrick

    SoBaldrick Well-Known Member

    Joined:
    Sep 15, 2015
    Messages:
    99
    Likes Received:
    66
    well I never, turned the glass over to other side, and it's now working.....
     
  3. SoBaldrick

    SoBaldrick Well-Known Member

    Joined:
    Sep 15, 2015
    Messages:
    99
    Likes Received:
    66
    no ignore that, worked once....
     
  4. SoBaldrick

    SoBaldrick Well-Known Member

    Joined:
    Sep 15, 2015
    Messages:
    99
    Likes Received:
    66
    double checked the wiring and all correct, printing a benchy as auto home is working after a fashion, not consistent, so will be double checking the wire connector tomorrow and may even run some temp wires to check.
     
  5. Springfield-Jack

    Springfield-Jack Well-Known Member

    Joined:
    Dec 20, 2015
    Messages:
    58
    Likes Received:
    4
  6. Rob Heinzonly

    Rob Heinzonly Well-Known Member

    Joined:
    Sep 20, 2015
    Messages:
    362
    Likes Received:
    124
    @SoBaldrick : I'm quite puzzled here. Are you absolutely 10000% sure you haven't switched the connectors for the X-axis and Z-axis end-stops ? It's the only thing I can think of.
     
  7. SoBaldrick

    SoBaldrick Well-Known Member

    Joined:
    Sep 15, 2015
    Messages:
    99
    Likes Received:
    66
    @Rob Heinzonly , X and Y end stops working fine, but will tripple check ;)
     
  8. SoBaldrick

    SoBaldrick Well-Known Member

    Joined:
    Sep 15, 2015
    Messages:
    99
    Likes Received:
    66
    Think I have found the issue, the electrolitic capacitor between the IR emitter and the sensors was tilted forward a little. straightened it up, and now triggering all the time. Auto Home and Bed Leveling working consistently so far.
     
    Thomas, Steven Burns and Mike Kelly like this.

Share This Page