Marlin wrangling the hotend fan

Discussion in 'E3D-v6 and Lite6' started by JustinSB, Mar 18, 2018.

Tags:
  1. JustinSB

    JustinSB Member

    Joined:
    Mar 3, 2018
    Messages:
    6
    Likes Received:
    1
    I have been trying to get my E3D Lite6 hotend fan to only turn on when I fire up the extruder.

    This is all built into Marlin 1.1.17 in Configuratiuon_adv.h & I'm using a Geeetech GT2560 RevA+ board.

    Code:
    /**  
     *Extruder cooling fans
     * Extruder auto fans automatically turn on when their extruders'
     * temperatures go above EXTRUDER_AUTO_FAN_TEMPERATURE.
     * Your board's pins file specifies the recommended pins. Override those here
     * or set to -1 to disable completely.
     * Multiple extruders can be assigned to the same pin in which case
     * the fan will turn on when any selected extruder is above the threshold.
     */
    #define E0_AUTO_FAN_PIN  -1  // I THINK THIS MY E3D Lite6
    #define E1_AUTO_FAN_PIN -1
    #define E2_AUTO_FAN_PIN -1
    #define E3_AUTO_FAN_PIN -1
    #define E4_AUTO_FAN_PIN -1
    #define EXTRUDER_AUTO_FAN_TEMPERATURE 50
    #define EXTRUDER_AUTO_FAN_SPEED   255  // == full speed
    & if I look at the pins_GT2560_REV_A.h file, it gives me
    Code:
    //
    // Temperature Sensors
    //
    #define TEMP_0_PIN          8
    #define TEMP_1_PIN          9
    #define TEMP_BED_PIN       10
    
    //
    // Heaters / Fans
    //
    #define HEATER_0_PIN        2
    #define HEATER_1_PIN        3
    #define HEATER_BED_PIN      4
    #define FAN_PIN             7
    However, it doesn't appear to matter what I set define E0_AUTO_FAN_PIN to (I've tried 2 and 8), as the fan always stays on. What am I doing wrong? It seemed like it should have been really simple, but...
     

Share This Page