My First Print using OctoPrint (Z movement counter intuitive)

Discussion in 'Calibration, Help, and Troubleshooting' started by Old_Tafr, Apr 3, 2016.

  1. Old_Tafr

    Old_Tafr Well-Known Member

    Joined:
    Mar 7, 2016
    Messages:
    560
    Likes Received:
    75
    Worked fine but for two or three things...

    At the start of the print the heads didn't move to the wiper so a blob of PLA formed on the nozzle on the bed (printer was at home in X Y and Z. Not a problem as in printing the raft it detached out of the way of the print, but I would have thought a wipe would always be before the start ........... maybe I added the command in the wrong part of the script. (previous post)

    Via OctoPrint the X and Y manual movement (arrows in "Control" are good, X left is left ... Y back is away from the front, BUT Z it is as if you are moving the heads not the bed (confusing) so hitting the DOWN arrow moves the bed UP (dangerous) as if the control is meant for the heads on a printer with a fixed Z plane.

    (Just tried home icon from OctoPrint..........heads move to home in X-Y but the bed does not move up, no movement of Z at all? (Doh... there is a separate home for Z ! )

    Is this normal.......... did I miss a config somewhere.......... and if I didn't is there a way to switch the direction of movement of Z and also get the home icon to actual home?
     
    #1 Old_Tafr, Apr 3, 2016
    Last edited: Apr 3, 2016
  2. Sarah Nicholson

    Sarah Nicholson Well-Known Member

    Joined:
    Dec 20, 2015
    Messages:
    319
    Likes Received:
    114
    There is an option in the printer profile in Octoprint to invert the axis direction. If you go to Settings -> Printer Profiles and edit your current profile, next to each axis there is a 'Invert control' checkbox, make sure it is checked for the Z axis.
     
    Old_Tafr likes this.
  3. Old_Tafr

    Old_Tafr Well-Known Member

    Joined:
    Mar 7, 2016
    Messages:
    560
    Likes Received:
    75
    Thanks...... :)

    If anyone tries this It takes a reboot of the printer to take effect
     

Share This Page