Octopi on Pi 3

Discussion in 'Guides, Mods, and Upgrades' started by Dr Jeep, Mar 10, 2016.

  1. Dr Jeep

    Dr Jeep Well-Known Member

    Joined:
    Sep 12, 2015
    Messages:
    530
    Likes Received:
    169
    Just a heads up, the current image builds for OctoPi do not support the Rpi 3 (Wifi and BT support not enabled) and more importantly the Device Tree Blob for the new hardware is missing so it won't even boot.

    So if you want to do octopi on the new Pi 3 then you'll either need to do what I am doing and build it up on a new installation of raspbian with the manual installation method or wait until octopi is updated.
     
    Mike Kelly likes this.
  2. Paul Seccombe

    Paul Seccombe Well-Known Member

    Joined:
    Oct 22, 2015
    Messages:
    74
    Likes Received:
    27
    The nightly build of OctoPi works on the Pi3. I haven't connected it to the Bigbox yet but everything appears to be running fine and others have reported it working.
     
  3. JMG

    JMG New Member

    Joined:
    Oct 9, 2017
    Messages:
    1
    Likes Received:
    0
    Hi all,

    I just found this forum. I am running Octopi on a RasPi3. I am using the 0.14 release of Octopi. I have been struggling to get the Wi-fi running. If read your posts that this version does not support WiFi on the Pi3. Is that correct? So, should I install a different build or wait for a final release?

    Thanks,
    John
     
  4. Jari

    Jari Member

    Joined:
    Jun 6, 2016
    Messages:
    4
    Likes Received:
    1
  5. Jari

    Jari Member

    Joined:
    Jun 6, 2016
    Messages:
    4
    Likes Received:
    1
    #5 Jari, Oct 9, 2017
    Last edited: Oct 9, 2017
  6. Falc.be

    Falc.be Well-Known Member

    Joined:
    Sep 4, 2015
    Messages:
    244
    Likes Received:
    38
    i have been running octopi on a rp3 without problems for a year
     
  7. jfb

    jfb Well-Known Member

    Joined:
    Mar 30, 2016
    Messages:
    91
    Likes Received:
    18
    I've just downloaded the latest OctoPi 0.14 from https://octopi.octoprint.org/,

    Just following the install steps 1-4 on that page worked perfectly for me on a brand new PI with new SD card.

    Sorry, I have no idea what might be wrong with your setup - about the only thing I can suggest is that you redo the steps, paying particular attention to configuring the wifi settings. apart from that you may find you can't find the PI by name and will need to use the IP address (that will depend mostly on your PC setup).

    At least we know that that image does support the PI 3 - hope that helps...
     

Share This Page