OctoPi running, but no video

Discussion in 'Calibration, Help, and Troubleshooting' started by Steven, May 23, 2016.

  1. Steven

    Steven Well-Known Member

    Joined:
    Sep 4, 2015
    Messages:
    185
    Likes Received:
    19
    Yes I checked the cabling. Any best way to troubleshoot?
     
  2. Rob Heinzonly

    Rob Heinzonly Well-Known Member

    Joined:
    Sep 20, 2015
    Messages:
    362
    Likes Received:
    125
    Is the red light on the Pi camera on ?
     
  3. Henry feldman

    Henry feldman Well-Known Member

    Joined:
    Sep 5, 2015
    Messages:
    969
    Likes Received:
    389
    And you started the video stream from the menu at the top?
     
  4. Steven

    Steven Well-Known Member

    Joined:
    Sep 4, 2015
    Messages:
    185
    Likes Received:
    19
    I found the issue... the thin cable needed to be reseated.
    But now the video that comes on is a snapshot, hardly updates.
     
  5. Henry feldman

    Henry feldman Well-Known Member

    Joined:
    Sep 5, 2015
    Messages:
    969
    Likes Received:
    389
    That is a mode. You can set whether you get snapshots or actual streaming video.
     
  6. jet

    jet Well-Known Member

    Joined:
    Mar 29, 2016
    Messages:
    199
    Likes Received:
    20
    Also getting no image: cable looks to be set properly, red LED on the camera, camera lens protector thing removed. When I roll over the image space in Control, I get the classic "dead image" placeholder. Before I open up the bottom (again) I'm wondering if there's any software problems I should look at?

    I took a look at the /root/bin/webcamd file and noticed it was set to "auto" and that the webcamd logs show it looking on USB. I changed it to
    camera="raspi"
    and also tried it with a spare raspi camera (v1.30) and got the same error:

    $ sudo /root/bin/webcamd
    Starting up webcamDaemon...

    --- Configuration: ----------------------------
    camera: raspi
    usb options: -r 640x480 -f 10
    raspi options: -fps 10
    -----------------------------------------------

    No camera detected, trying again in two minutes

    (it repeats that last line)
     
  7. Henry feldman

    Henry feldman Well-Known Member

    Joined:
    Sep 5, 2015
    Messages:
    969
    Likes Received:
    389
    Check the web cam settings in octoprint->settings as the URL must match (that happened to me, when I forgot to click static lease on my router and for some reason got a new address via DHCP and the URL didn't match so the link became broken)
     
  8. PsyVision

    PsyVision Moderator
    Staff Member

    Joined:
    Sep 4, 2015
    Messages:
    798
    Likes Received:
    248
    Octoprint just steals the image from MJPG Streamer that runs on the Pi on port 8080, so goto the following URL:

    http://192.168.1.156:8080/

    And see if you can see an image?
     
  9. jet

    jet Well-Known Member

    Joined:
    Mar 29, 2016
    Messages:
    199
    Likes Received:
    20
    I think the problem is that webcamd isn't finding the camera.
    "No camera detected, trying again in two minutes"

    If I go to http://10.0.1.80 I see octopi, but there's nothing listening at 8080:

    $ telnet 10.0.1.80 8080
    Trying 10.0.1.80...
    telnet: connect to address 10.0.1.80: Connection refused
    telnet: Unable to connect to remote host

    Digging through the webcamd code, I've found a problem camera detection. Maybe the red LED isn't a sign the camera is fully connected? Time to open up the base.

    $ vcgencmd get_camera
    supported=1 detected=0
     

Share This Page