Problem with hybrid Titan extrusion calibration

Discussion in 'Calibration, Help, and Troubleshooting' started by fpex, Jun 17, 2016.

  1. fpex

    fpex Well-Known Member

    Joined:
    Oct 18, 2015
    Messages:
    621
    Likes Received:
    58
    I am now running the calibration of the extruders (finally after all sort of issues) on the hybrid for the first time and I have a quite a weird problem.

    My hybrid uses a E3D want motor (200 steps) on the bowden with driver set as from wiki and a stepper online pancake 200 steps with drivers set somewhat lower (since it needs less current).
    I am using everyday pla on both.

    When I run the calibration:

    Bowden extruder extrudes 3.3 cm and the direct extrudes 9.8 cm (almost correct).

    Considering they are both 200 steps, this result is highly weird! Any idea what I could do ?
    Thanks


    Extruder 1 is http://e3d-online.com/Electrical/Stepper-Motors/NEMA17-40Ncm
    Extruder 2 is http://eu.stepperonline.com/nema-17-bipolar-step-motor-29v-07a-18ncm255ozin-17hs100704s-p-260.html
     
    #1 fpex, Jun 17, 2016
    Last edited: Jun 17, 2016
  2. fpex

    fpex Well-Known Member

    Joined:
    Oct 18, 2015
    Messages:
    621
    Likes Received:
    58
    For reference this is from the config

    #define DEFAULT_AXIS_STEPS_PER_UNIT {160,180,3200,417.5} // titan extruders 200 steps, Z motor 400 steps
    #define DEFAULT_MAX_FEEDRATE {150, 150, 6, 25} // (mm/sec)
    #define DEFAULT_RETRACT_ACCELERATION 3000 // E acceleration in mm/s^2 for retracts

    #define INVERT_E0_DIR true
    #define INVERT_E1_DIR false
    #define INVERT_E2_DIR false
    #define INVERT_E3_DIR false
     
  3. Alex9779

    Alex9779 Moderator
    Staff Member

    Joined:
    Sep 4, 2015
    Messages:
    2,405
    Likes Received:
    731
    Did you try to switch the the motor driver combination?
     
  4. fpex

    fpex Well-Known Member

    Joined:
    Oct 18, 2015
    Messages:
    621
    Likes Received:
    58
    Mmmm ..... I do have a spare driver also, I wold have to have yet another bad driver
     
  5. Mark_T

    Mark_T Well-Known Member

    Joined:
    Apr 23, 2016
    Messages:
    239
    Likes Received:
    34
    The Titan has a 3:1 gear ratio doesn't it?

    That is suspiciously the same as your error, no idea why or how that would be related, but I'm not a great believer in coincidences :)
     
  6. fpex

    fpex Well-Known Member

    Joined:
    Oct 18, 2015
    Messages:
    621
    Likes Received:
    58
    I agree, but the titan on the direct mount works fine, the other one not. and the steps and step settings are the same. The only difference is direct vs bowden, two different motors with same steps but different voltage/ampers and, thus, different driver setting.
    But to be fair the one making mistake is set up as it should :-(
     
  7. Alex9779

    Alex9779 Moderator
    Staff Member

    Joined:
    Sep 4, 2015
    Messages:
    2,405
    Likes Received:
    731
    No idea if it is a bad driver, easiest test would be to remove the nozzle connect the bowden motor to the other motor connector, send the firmware M302 to enable cold extrdues and the measure again... Just to see if the motor behaves different when connected to where the other motor behaves correct...
     
  8. fpex

    fpex Well-Known Member

    Joined:
    Oct 18, 2015
    Messages:
    621
    Likes Received:
    58
    If I extrude in air (not to the hot end) I het 11.5cm of filament out of the extruder ..... could it be that in bowden we need the drivers to provide more current then what indicated in the wiki?

    Checked: nozzle is perfectly clean so no obstruction problem
     
    #8 fpex, Jun 17, 2016
    Last edited: Jun 17, 2016
  9. Alex9779

    Alex9779 Moderator
    Staff Member

    Joined:
    Sep 4, 2015
    Messages:
    2,405
    Likes Received:
    731
    I don't believe this. I used both motor bundled with the Titans I ordered, one for direct, one for bowden and they extrusion was the same...
    And you have the bigger motor for the bowden so this should work with the settings, not the way you see it... This is really strange...
     
  10. Mark_T

    Mark_T Well-Known Member

    Joined:
    Apr 23, 2016
    Messages:
    239
    Likes Received:
    34
    No chance the bowden tube is moving at either end is there?
     
  11. fpex

    fpex Well-Known Member

    Joined:
    Oct 18, 2015
    Messages:
    621
    Likes Received:
    58
    increasing the power got me 1cm more extruded on hot end and the same 11.5cm when extruding in air.

    Bowden tube as long as it is fixed is ok.

    When I touch the filament, it feels like the extruder is missing steps because of the pressure when it goes through the hot end
     
  12. Alex9779

    Alex9779 Moderator
    Staff Member

    Joined:
    Sep 4, 2015
    Messages:
    2,405
    Likes Received:
    731
    At what feedrate are you testing the extrusion?
     
  13. fpex

    fpex Well-Known Member

    Joined:
    Oct 18, 2015
    Messages:
    621
    Likes Received:
    58
  14. Mark_T

    Mark_T Well-Known Member

    Joined:
    Apr 23, 2016
    Messages:
    239
    Likes Received:
    34
  15. fpex

    fpex Well-Known Member

    Joined:
    Oct 18, 2015
    Messages:
    621
    Likes Received:
    58
    mmm ... i might have both with a sloppy one, I need to check again not sure
     
  16. fpex

    fpex Well-Known Member

    Joined:
    Oct 18, 2015
    Messages:
    621
    Likes Received:
    58
  17. Sarah Nicholson

    Sarah Nicholson Well-Known Member

    Joined:
    Dec 20, 2015
    Messages:
    319
    Likes Received:
    114
  18. fpex

    fpex Well-Known Member

    Joined:
    Oct 18, 2015
    Messages:
    621
    Likes Received:
    58
    please do not tell me I am the MOST unlucky BB owner???
    Burnt rumba, missing micro barbs and screws, missing plastic tubes, defected drivers, etc etc ... and now even faulty titan???
     
  19. Sarah Nicholson

    Sarah Nicholson Well-Known Member

    Joined:
    Dec 20, 2015
    Messages:
    319
    Likes Received:
    114
    If you bought your Titans early on they are likely to have the sloppy gears, I ordered mine the day they were announced. It's the early adopter's curse ;) Although I've been quite lucky with the BB, I had no missing or defective parts other than the print fan cable which detached, and I got a replacement next day, same with the Titan gears.
     
  20. fpex

    fpex Well-Known Member

    Joined:
    Oct 18, 2015
    Messages:
    621
    Likes Received:
    58
    I will drop them yet an email :-(

    It might explain why the direct goes while the Bowden needing more force sees the filament slipping.
     

Share This Page