RRF3 bed settings

Discussion in 'Getting Started' started by ryan mckenna, May 2, 2020.

  1. ryan mckenna

    ryan mckenna Member

    Joined:
    Mar 12, 2020
    Messages:
    19
    Likes Received:
    3
    I am getting a not heating up fast enough error. 1.6 sec --- I have the e3d 300x300 110 v bed. what do i need to change?

    before i had it set up on RRF2 and my lights would dim a little. is there a way to adjust that 2.

    Code:
    ; Heaters
    M308 S0 P"bedtemp" Y"thermistor" T100000 B4138                       ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0                                                ; create bed heater output on bedheat and map it to sensor 0
    M143 H0 S120                                                         ; set temperature limit for heater 0 to 120C
    M307 H0 B0 S1.00                                                     ; disable bang-bang mode for the bed heater and set PWM limit
     
  2. dc42

    dc42 Well-Known Member

    Joined:
    Aug 16, 2016
    Messages:
    467
    Likes Received:
    207
    You need to tune the bed heater to get the correct M307 H0 settings.
     
    #2 dc42, May 2, 2020
    Last edited: May 3, 2020
  3. ryan mckenna

    ryan mckenna Member

    Joined:
    Mar 12, 2020
    Messages:
    19
    Likes Received:
    3
    works now thank you.
     
  4. Spoon Unit

    Spoon Unit Well-Known Member

    Joined:
    Sep 6, 2015
    Messages:
    1,546
    Likes Received:
    481
    Did you tune it with M303 or just use the settings from dc42's bed? Mine is set to

    M307 H0 A346.1 C330.4 D1.9 S1.00 V24.2 B0

    This might have been tuned sometime back on a different algorithm, thinking about it. To tune you use

    M303 H0 S80

    To tune the bed for heating to 80 degrees C. You might want to tune it for heating to a hotter temperature. Follow the console commands once tuning is complete. M500 will save the settings in config-override.g and you can ensure these are loaded by inserting M501 to the end of config.g
     
  5. dc42

    dc42 Well-Known Member

    Joined:
    Aug 16, 2016
    Messages:
    467
    Likes Received:
    207
    Oops, my M307 settings don't look right for a bed, I think they must be for a hot end. Spoon Unit's settings look much more likely, However, I suggest you remove the V24.2 parameter because the bed is AC mains powered, and that parameter is provided to allow RRF to compensate heater power for VIN voltage.
     
  6. ryan mckenna

    ryan mckenna Member

    Joined:
    Mar 12, 2020
    Messages:
    19
    Likes Received:
    3
    I did the pid tune. Before with RR2 my lights would dim every 5 or ten seconds after it heated up but the temp would fluctuate more. Now its like a strobe light with no fluctuation. Is that the difference between bang bang and pid. Should i use bang bang if i don't mind a little fluctuation? Is bang safer for my other electronics on the same plug.

    Can I use the S to lower my power to 0.80 %, Does it work with a AC bed
     
  7. Spoon Unit

    Spoon Unit Well-Known Member

    Joined:
    Sep 6, 2015
    Messages:
    1,546
    Likes Received:
    481
    That was what the firmware pasted into the config-override.g following M500 after a pid tune. Happy to remove it, but why is it there? Possible my bed heater is configured incorrectly, though it does work at present well enough.

    These are the bed heater settings

    M140 H0
    M308 S0 P"bedtemp" Y"thermistor" T100000 B4138 C0 ; Set thermistor
    M950 H0 C"bedheat" T0 ; Bed heater
    M143 H0 S225 ; Set temperature limit for heater 0 to 225C

    24.2 isn't mentioned anywhere there.

    As mentioned, I probably tuned this long ago with RRF2, so I'll go through all of the heaters I think and re-tune.
     

Share This Page