Rust in Titan lid bearing...

Discussion in 'Titan' started by threephourths, Jan 9, 2018.

  1. threephourths

    threephourths Member

    Joined:
    Jan 4, 2018
    Messages:
    3
    Likes Received:
    1
    I found rust all over the hobbed gear shaft and a broken lid bearing with rust covering the interior ball bearings tonight (the lid bearing was damaged so bad I could see into it), after having only had this for one month. I contacted the seller from Amazon but I thought I would make a post due to the fact that I have noticed a few other users posting about rust as well. Check out your lid if you have bought a Titan in the past few months.....
     

    Attached Files:

    Benjamin Lakeit likes this.
  2. Benjamin Lakeit

    Joined:
    Jan 14, 2018
    Messages:
    3
    Likes Received:
    0
    Hi there,
    same issue here with me. I got annoyed by a squicking sound the Titan made during printing, thus I just disassembled it today to find the culprit. The entire bearing area was covered in rust. I gave it a fair amount of oiling, but I doubt this will last very long :-(.
    I've bought the Titan many months back (actually March 2017), thus there seems to be an issue which is dating longer back (I'm pretty sure that my Titan did not get wet during time of operation, except for standard humidity in the air).
    Best regards,
    Benjamin
     
  3. threephourths

    threephourths Member

    Joined:
    Jan 4, 2018
    Messages:
    3
    Likes Received:
    1
    I contacted E3D support directly about this and got a reply finally. They are aware of this issue and they are going to get replacement bushings sometime this week. They are unsure about how to proceed with the replacement process however. I would contact them directly about this so you will be in the loop about how they will proceed.

    For the time being, I replaced both of the MR95ZZ bearings that the hobbed bolt uses. Its working for now but Im curious to see these bushings
     
  4. JagUK

    JagUK Member

    Joined:
    Feb 8, 2018
    Messages:
    2
    Likes Received:
    0
    IMG_2140.JPG I have had mine less than a month and it is squealing on every print ....... this weekend I will inspect the bearing in my Titan...... with less than a month old purchase this should not be happening

    Yes mine is the same !!...used it for less that 30 days from new and bearing is seized with rust

    Sent E3D 2 messages today requesting a refund , not heard or had a reply yet in any form.
    Seems their customer relations is as good as the products
     
    #4 JagUK, Feb 8, 2018
    Last edited: Feb 9, 2018
  5. threephourths

    threephourths Member

    Joined:
    Jan 4, 2018
    Messages:
    3
    Likes Received:
    1
    Welcome to the party pal! Good luck trying to get a response. I filled out the form online in their "Bearing Gate" blog, but haven't heard a word. My seller an amazon hasent responded either. So now Im stuck with this thing
     
  6. JagUK

    JagUK Member

    Joined:
    Feb 8, 2018
    Messages:
    2
    Likes Received:
    0
    That's why I love trading standards and Paypal
     
  7. Spoon Unit

    Spoon Unit Well-Known Member

    Joined:
    Sep 6, 2015
    Messages:
    1,154
    Likes Received:
    341
    You could just ring their number rather than wait for a response from what is most likely a very long list of inbound email?
     
    Antoine likes this.
  8. Montague Flange

    Montague Flange Active Member

    Joined:
    Jul 10, 2016
    Messages:
    44
    Likes Received:
    7
    well I fille din the form ages ago and have heard nothing back from them.
     
  9. Webdad

    Webdad Member

    Joined:
    Sep 22, 2017
    Messages:
    5
    Likes Received:
    0
    They are probably working through the list. I filled in my form quite a while ago as well, and just received replacement cover and two bearings yesterday. It came fed-ex from Great Britain.
     
  10. Montague Flange

    Montague Flange Active Member

    Joined:
    Jul 10, 2016
    Messages:
    44
    Likes Received:
    7
    I reported it on my Titan long before the aero came out as well
     
  11. Paul Miller

    Paul Miller New Member

    Joined:
    Feb 23, 2018
    Messages:
    1
    Likes Received:
    0
    I have found the same issue with my "Designed by E3D" extruder that came stock with my Tevo Delta. I assume that this would not be covered under the E3d warranty. Does anybody know the bearing type I should replace with?
     
  12. Antoine

    Antoine Well-Known Member
    Staff Member

    Joined:
    Apr 3, 2017
    Messages:
    102
    Likes Received:
    18
    We are currently still working through the backlog of bearing issues at the moment, and our customer service is working non stop to get replacement parts out to you guys. I understand the frustration, but please believe us when we tell you we are doing all we can to bring this to an end.
    If you reported the Titan before Aero came out, you can't have done it in the same form as the bearinggate form. Please fill in the bearinggate form to be sure to have an answer and replacement parts sent out.
     
  13. Nik

    Nik Member

    Joined:
    Oct 7, 2017
    Messages:
    13
    Likes Received:
    0
    I've encountered the same problem with an Aero that would squeak during retracts and click occasionally. I've shot E3D an email about replacements but honestly, considering how backlogged the customer service is right now and how long shipping from the UK would take, i'd rather just buy some bearings locally instead of wating a month. I know they're MR95ZZ types, but i'd like to avoid whatever brand the current rusting ones are. The most commonly available here are made by KBS - would those be ok?
     
  14. Antoine

    Antoine Well-Known Member
    Staff Member

    Joined:
    Apr 3, 2017
    Messages:
    102
    Likes Received:
    18
    They should be fine. We are not experiencing any QC issues with the Titan Aero though.
     
  15. Nik

    Nik Member

    Joined:
    Oct 7, 2017
    Messages:
    13
    Likes Received:
    0
    Thanks. It's very similar to JagUK's photo with a streak of rust on the hob, just not as severe. Nothing wrong with the lid obviously, since its aluminium.
     

Share This Page