COMPLETE S3D Cooling Options (Blip fans option)

Discussion in 'Guides, Mods, and Upgrades' started by Alex9779, Mar 16, 2016.

  1. Alex9779

    Alex9779 Moderator
    Staff Member

    Joined:
    Sep 4, 2015
    Messages:
    2,405
    Likes Received:
    731
    A thing I realized lately is that S3D has a cooling option to blip fans to 100% when starting them.
    This should help to get a fan running if it was not before an if you are going to set some low value.
    Because of its moment of interia the fan might not start if you want to go with small speeds. This setting should prevent that:
    Blip fan.PNG

    Unfortunately S3D can do this only be inserting GCODE. And it does it like this:
    Code:
    M106 S255
    G4 P500
    M106 S76
    The first line sets the cooling fans to 100%.
    The second line waits 500ms.
    The third line sets the cooling fans then to 30%.

    The bad thing is the wait. I saw in my prints sometimes bubbles and realized they came from that short park when the fans are blipped.

    So I turned that option of and didn't have a problem.

    My recent findings also substantiate that this setting is absolutely not needed in the slicer to be active:
    Code:
    // When first starting the main fan, run it at full speed for the
    // given number of milliseconds.  This gets the fan spinning reliably
    // before setting a PWM value. (Does not work with software PWM for fan on Sanguinololu)
    #define FAN_KICKSTART_TIME 100
    This is an extract of the advanced configuration of the firmware for the BigBox.
    You see there is an option active which does exactly what the option in the slicer should do.

    So there is not need to do it twice, the firmware does it better without stopping the head for half a second.

    Just turn it off in your slicer...
     
    #1 Alex9779, Mar 16, 2016
    Last edited: Mar 17, 2016
    Spoon Unit likes this.

Share This Page