Sensorless Homing Crashing X into Home only after home-Y

Discussion in 'Tool heads & ToolChanger' started by KHH, Nov 15, 2020.

  1. KHH

    KHH Member

    Joined:
    Nov 15, 2020
    Messages:
    12
    Likes Received:
    0
    When I home-all, my X will just crash and grind into the x-home position. This only occurs AFTER y is homed. If I home X when Y is not zero, it homes fine. So should I tweak the sensorless homing? And if so where do I start? As I suspect the homing is having issues because TWO motors need to stall in order to trip the stall?
     
  2. KHH

    KHH Member

    Joined:
    Nov 15, 2020
    Messages:
    12
    Likes Received:
    0
    I am not sure as to why, but after Y homes, the last gcode in homey.g is M574 X1 S0, after that runs, home X is impossible. So I have removed that line from the end of homey and homex, and now homing works fine.

    If I have this line in ANY of the homeX or homeY files, I can only home once, and never again. As it just grinds the home pos.
     
  3. dc42

    dc42 Well-Known Member

    Joined:
    Aug 16, 2016
    Messages:
    480
    Likes Received:
    213
    I am not surprised, because that command switches from stall homing to endstop switch homing. It should not be in your homing files.
     
  4. KHH

    KHH Member

    Joined:
    Nov 15, 2020
    Messages:
    12
    Likes Received:
    0
    These commands are in the Config shipped with the changer
     
  5. Rene

    Rene Active Member

    Joined:
    Sep 1, 2019
    Messages:
    33
    Likes Received:
    16
    You are right, I did create a pull-request for removing the last line from homex.g and homey.g aswell.
     
    Olle Wreede and KHH like this.

Share This Page