SOLVED squashed bottom layers

Discussion in 'Calibration, Help, and Troubleshooting' started by markoaurelije, Mar 31, 2017.

  1. markoaurelije

    markoaurelije Active Member

    Joined:
    Dec 21, 2015
    Messages:
    43
    Likes Received:
    6
    So, this seems related to issue https://forum.e3d-online.com/index.php?threads/lower-layers-quality.2603/

    Why would my BigBox (v1.1 dual hybrid - Titan, Marlin RC8) have bottom X layers squashed and rest of the layers perfectly normal.
    My parts are coming out shorter for cca 1.8mm and allways because of bottom 5mm.
    Didn't see that before, but not sure if this was happening from the beginning.
    Marlin's LCD shows consistent Z height movements even for bottom layers, but like the bed is not moving accordingly.

    The problem persists even if I change Z resolution in S3D.
    The test part in the picture is with 0.3 mm layers.

    Can anyone help? Maybe @Greg Holloway ?

    BTW: Z driver's voltage tuned to 0.58V
     

    Attached Files:

  2. Greg Holloway

    Greg Holloway Administrator
    Staff Member

    Joined:
    Sep 4, 2015
    Messages:
    565
    Likes Received:
    397
    Up the voltage to about 0.8 (assuming you use a single driver for two motors).

    Turn off z-hop (z change during retraction).

    Slow down the printing.

    check the bed isn't sticking for the first 5mm.

    Check nothing is lose.
     
  3. markoaurelije

    markoaurelije Active Member

    Joined:
    Dec 21, 2015
    Messages:
    43
    Likes Received:
    6
    Thanks Greg,

    I actually found out what was causing the issue.

    It's Marlin's LEVELING_FADE_HEIGHT feature...

    // Gradually reduce leveling correction until a set height is reached,
    // at which point movement will be level to the machine's XY plane.
    // The height can be set with M420 Z<height>
    #define ENABLE_LEVELING_FADE_HEIGHT


    I had it setup with M420 Z6 in the S3D startup script.
    When turned off issue is gone.
     
  4. Greg Holloway

    Greg Holloway Administrator
    Staff Member

    Joined:
    Sep 4, 2015
    Messages:
    565
    Likes Received:
    397
    Wow, I'd have never caught that one lol.
     
  5. Paul Begley

    Paul Begley Well-Known Member

    Joined:
    Mar 24, 2016
    Messages:
    81
    Likes Received:
    19
    How level is your bed to start with? What bed levelling process are you using?
    Have you raised this as a possible bug? My understanding of the that feature is that over x layers/height, the need for any bed levelling correction is reduced, i.e. z is not changed as a function X,Y position. So assuming your starting with a fairly level bed, It shdoul gradually fade out, not a sudden change as seen on your prints.

    Interesting, I must check mine, as i know wi have that enabled.
     
  6. markoaurelije

    markoaurelije Active Member

    Joined:
    Dec 21, 2015
    Messages:
    43
    Likes Received:
    6
    My bed is somewhat level +/-0.5mm. Using MBL to compensate.
    My understanding was that with this feature enabled the need for compensation would cease after Z height you put in M420. And indeed the compensation stops accordingly (observed by Z motors are idle during movements on layers above height defined with M420).
    But layers below this height defined with M420 are squashed.
    My specific scenario was with M420 Z6... I observe squashed layers below Z=6mm and I lose 2mm in Z dimension of my parts.
    If anyone can confirm similar behaviour I suspect it's a bug in the feature.
     
    #6 markoaurelije, Apr 1, 2017
    Last edited: Apr 1, 2017

Share This Page