Squeaking Titan Extruder

Discussion in 'Titan' started by dadiy, Aug 21, 2017.

  1. dadiy

    dadiy Member

    Joined:
    Jul 19, 2017
    Messages:
    5
    Likes Received:
    0
    I have a Titan extruder with the pancake motor and bowden tube adapter, it's only a few weeks old, on retractions, the Titan lets out a squeak each time. During regular extrusion, it appears to be fine.

    I searched the forum button couldn't find any tips, has anyone any suggestions how to silence the extruder during retracts?
     
  2. Grooperdude

    Grooperdude Member

    Joined:
    Aug 31, 2017
    Messages:
    2
    Likes Received:
    0
    Maybe... did you happen to add a washer to the screw going throw the clear case, through the hobbed great and into your stepper motor? if so, remove it.
     
  3. dadiy

    dadiy Member

    Joined:
    Jul 19, 2017
    Messages:
    5
    Likes Received:
    0
    Yes, I had added the washer, I've now removed it and added a little lithium grease to the bolt, fingers crossed that will solve it.

    I checked some images and many titans are shown with the washer installed?

    UPDATE:

    After removing the washer the squeak is now more of a creak. I also found that you can't really tighten that screw or the extruder doesn't have the power to move the filament, perhaps getting this small pancake motor was a bad idea.
     
    #3 dadiy, Sep 5, 2017
    Last edited: Sep 6, 2017
  4. D Clark

    D Clark New Member

    Joined:
    Sep 27, 2017
    Messages:
    1
    Likes Received:
    0
    I just rebuilt my Titan to correct an orientation issue, and I added the washer to the bolt that goes through the extruder gear, and now my Titan squeaks, not always, but fairly often. What up? Anyone know?

    I found that I had the "can't tighten" issue with that bolt and I fixed it by going to a longer bolt that bottoms out before it gets tight on the plastic. The washer I put in to close the gap between the head of the bolt and the plastic case. Now it squeaks. That does not jive, it shouldn't cause that. So, E3D, what causes the annoying squeak?

    Thanks,
    DLC
     
  5. Vikas Gupta

    Vikas Gupta New Member

    Joined:
    Oct 9, 2017
    Messages:
    1
    Likes Received:
    0
    Hello dadly,
    I faced the same problem in one of my titan. It was squeaking in both way. So i checked and fount that bearing in TITAN COVER (bearing 5/9) was the culprit. So I oiled and put it back. Now no squeaking anymore. You should also check that. Change it or use machine oil. May be it will solve your issue. Good luck and please update if it solves.
     
    #5 Vikas Gupta, Oct 9, 2017
    Last edited: Oct 10, 2017
  6. dadiy

    dadiy Member

    Joined:
    Jul 19, 2017
    Messages:
    5
    Likes Received:
    0
    I tried soaking the bearing in oil and it didnt fix the problem, but it certainly changed the noise it makes, so I think I need to replace the bearing. Question is does anyone know what the bearing are?
     
  7. TheCure

    TheCure Member

    Joined:
    Nov 28, 2017
    Messages:
    3
    Likes Received:
    0
    I had the same squeaking problem on my new titan aero. I was wondering what could have been making the faint intermittent squeak noise until it failed yesterday and i noticed the bearing in aluminum front piece had disintegrated. Shavings and black dust everywhere.
    Apparently im not the first according to the vendor.
     
  8. Alex9779

    Alex9779 Moderator
    Staff Member

    Joined:
    Sep 4, 2015
    Messages:
    2,405
    Likes Received:
    731
    I had a problem with a bearing in a Titan some time ago.
    I ordered replacement bearings from Misumi which worked great.
    Here is a link: https://de.misumi-ec.com/vona2/detail/221000058378/?HissuCode=F-WBC5-9ZZ1/1K
    Part number is
    F-WBC5-9ZZ1/1K
     

Share This Page