Temp fix for 3mm filament (un)loading

Discussion in 'Titan' started by Alex9779, Jun 2, 2016.

  1. Alex9779

    Alex9779 Moderator
    Staff Member

    Joined:
    Sep 4, 2015
    Messages:
    2,405
    Likes Received:
    731
    I ordered a Titan for my UM2 and I have still some 3mm filament to print. After mounting I realized the I was not able to easy (un)load the filament because the lever hits the case before the filament is free and not pressed against the drive gear.
    E3D is aware of the issue and announced updated parts but since it is still some weeks until they are available (as support told me today). So I decided to make a quick fix because feeding the filament through the long bowden prune of the UM2 sucks.

    Here are two pics before and after, I just cut away some of the lever where it hits the case:
    image.jpeg image.jpeg
     
    #1 Alex9779, Jun 2, 2016
    Last edited: Jun 5, 2016
    Sanjay likes this.
  2. danzca6

    danzca6 Well-Known Member

    Joined:
    Apr 26, 2016
    Messages:
    83
    Likes Received:
    6
    They should have a new version of the lever available to fix this sometime this month. Nice job on the homebrew solution.
     
  3. TimV

    TimV Well-Known Member

    Joined:
    Mar 13, 2016
    Messages:
    151
    Likes Received:
    26
  4. Alex9779

    Alex9779 Moderator
    Staff Member

    Joined:
    Sep 4, 2015
    Messages:
    2,405
    Likes Received:
    731
    http://e3d-online.com/Titan-Extruder
    Section "Performance. Power. Push.
    "Please note:- due to a small, last-minute design change, there is an issue with Titan in 3mm, the result of which is that the filament will always engage with the drive gear."

    If you compare the two pictures closely you will see that I removed some material on the second one...

    My information from support of last week was that it will take 6-8 weeks until the new levers are available.
     
    #4 Alex9779, Jun 5, 2016
    Last edited: Jun 5, 2016
    Sanjay and TimV like this.
  5. Sanjay

    Sanjay Administrator
    Staff Member

    Joined:
    Feb 27, 2014
    Messages:
    125
    Likes Received:
    118
    We are creating a new version of this part that fixes this issue. As @Alex9779 mentions however it takes quite a while to cut, sample and generally bring an injection mould online. We expect this to take a few weeks before we have updated parts.

    This fix should work just fine, with no impact on the the performance or function of your Titan. If you're experiencing problems do give this a go, not ideal I realise, but consider it an "approved hack" - if you screw it up and break your lever in the course of cutting it up we'll replace it free of charge.

    When the new levers come in we'll gladly ship you a new part if you really want one, but in most cases it's a non-issue or something that can be fixed with a snip of a side cutter.
     

Share This Page