Z-Axis bed Level problem

Discussion in 'Calibration, Help, and Troubleshooting' started by Francesco, May 15, 2016.

  1. Rob Heinzonly

    Rob Heinzonly Well-Known Member

    Joined:
    Sep 20, 2015
    Messages:
    448
    Likes Received:
    174
    Agree with Alex, if you hookup Octopi you could see some logs in the terminal window of Octopi when the printer is (trying to) print the Benchy.
     
  2. Old_Tafr

    Old_Tafr Well-Known Member

    Joined:
    Mar 7, 2016
    Messages:
    721
    Likes Received:
    92
    Would it not be useful to see if commands from OctoPrint work? as a step toward seeing what works and what does not, for example it's possible to extrude filament from the Control tab.

    So a test working backwards to find a point where things do work would be to simply set the temp on one nozzle, wait for the fan to come on at 40oC watch the temp hit xxoC then hit the button (can say which as I don't have it running but they are fairly obvious) to push some filament through out of the nozzle, and then maybe retract a few mm just to see it happen.

    If this works then try another simple test.

    I have not tried this myself (anyone who know gcode please help here) but it must be possible to put some gcode commands in the terminal and see the printer so something, even if it is just to move the X-Carriage or the bed?

    If this works then move on again.

    If it possible to do the above then commands must be getting to the motors (X, Y, Z and extruder(s) via the Rumba. Plus command smust be getting from Pi to Rumba to motors etc.

    So then it would be why doesn't a file directly on an SD card send commands (or maybe someone has a simpler test file that can be put on the SD card, to again execute some simple actions.........
     
  3. Stefan

    Stefan Well-Known Member

    Joined:
    Feb 17, 2016
    Messages:
    324
    Likes Received:
    43
    Hi
    I fighting with a dual 1.0 to dual 1.1 hybrid Titan upgrade.....

    What I noticed today was that the default Hotend PID settings are not working for me.
    It behaves like yours, set temp, it heats up and nothing except the temperature is swinging or oscillating or rising and falling constantly,...

    set to 210 got to 215 falls to 207 and up to 214, 206, 216,..... and does not stay around 210 (+-2)....

    I tried to PID tune with this
    Code:
    M303 E0 S210 C8
    
    Note To do this you need a Terminal...
    This could be a setup Octoprint or connect it to a PC
    by USB and use the e.g.
    • fronterface
    • Arduino serial Monitor (with CR and NL)
    • Simplify3D, Machine Control Panel (Gear in Toolbar) (but I do not like it)
    • or any other serial termial where you can ser 230400 Baud and "send CR+NL"
    which results in
    Code:
    #define  DEFAULT_Kp 27.02
    #define  DEFAULT_Ki 5.09
    #define  DEFAULT_Kd 35.86
    
    but that did not work.. so I used some old values I saved... thy worked.
    Code:
    M301 P20.93 I1.36 D80.77
    M500
    the M500 save it to the EEPROM

    Hope this helps
     
  4. Francesco

    Francesco Member

    Joined:
    Nov 5, 2015
    Messages:
    13
    Likes Received:
    0
    Hi
    ok, I connected to raspberry pi with octoprint, I clicked settings and
    follow the configuration as the online manual of octoprint
    Then I try to print from bigBox screen the Benchy and nothing happen as before
    I checked in the terminal window, this is the log:

    Send: M105
    Recv: ok T:139.1 /0.0 B:44.5 /0.0 B@:0 @:0
    Recv: echo:enqueueing "M23 3dbenc~1.gco"
    Recv: echo:enqueueing "M24"
    Recv: echo:Now fresh file: dbenc~1.gco
    Recv: open failed, File: dbenc~1.gco.
    Send: M105
    Recv: ok T:137.8 /0.0 B:44.4 /0.0 B@:0 @:0
    Send: M105
    Recv: ok T:134.1 /0.0 B:44.2 /0.0 B@:0 @:0

    What do these logs mean?

    Then I try to print from octoprint web interface the Benchy
    and the printer start to move try to print the Benchy but without extrude the filament :-(

    At this point I rebooted the octoprint and switched off the printer
    When I switched on the printer and restarted the octoprint WebPage with the new IP of the raspberry pi, the Webpage the printer appeared without the setting menu (see figure attached).

    What happens? Why I can not connect anymore to the printer?
     

    Attached Files:

  5. Stefan

    Stefan Well-Known Member

    Joined:
    Feb 17, 2016
    Messages:
    324
    Likes Received:
    43
    First this http://reprap.org/wiki/G-code is your friend when it comes to g-code

    That M105 is Octoprint asking the printer for temperatures.
    and your Extruder (T for toolt) is right now at 139.1 C set to 0.0 C, that's why it is falling heating is off.
    Your bed (B) 44.5C and it#s off too.

    Not 100% sure but it looks like there is trouble reading the SD card.

    Are the temperatures set correctly?
    Because there is a minimum temp (~175C) before the extruder moves, to prevent damage I think.

    But on the brightside it sound it could read the SD card.

    In my experience you have been to quick to access the Webpage. the Octoprint software needs some seconds to fully load after (re-)boot, most likely a F5 page reload will fix it.
     

Share This Page